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Description Available 
in 

Version 

Incident 
# 

Global 
System 
Option 

# 

Clerk Code Maintenance Screen Enhancement – Active / Inactive 
Toggle 
A toggle button has been added for users to toggle between 
Active/Inactive/All Clerks.  Locked Clerk Codes will display as Active or 
All. 

 180478  

Foreign Currency Symbol Display 
Global System Option #586 will now determine which currency symbol 

will be displayed within Maestro.  For Example, configuring the 

symbol in global system option 586, will change the $. 

 181420 586 

Email Sent by Clerk Code for Front Desk, Spa and Facilities 
The Email Messages screen on a reservation now displays the Date 
Sent and Clerk Code Sent by.  

 167216  
 

Client Profile 2
nd

 Email Address Field  
A Second email address field was added to the client profile screen. 
Both emails will appear when sending confirmations from the guest 
reservation screen. Leave both emails to send to both or blank one out 
to send to only one. 

 149497  

 

Description Available 
in 

Version 

Incident 
# 

Global 
System 
Option 

# 

Client Code field now displays on the Client Code Lookup by Last 
Name Screen 
Added Client Code to the Client Name Look up screen from the A/R 
field on a Group Reservation.   When entering the first few letters of the 
A/R Name, look up screen will now display Client Name and Client 
Code 

 173224  

Meal Plan Guest List Report calculations for departure date 
correction.   
A correction has been made to the Meal Plan Guest List report to 
calculate the on the departure date in line with the Meal Plan Departure 
day configuration (Y or N)  

 173487 
 

 

Cancellation Policy Posting Code 
The Front Desk Cancellation Policy allows for configuration of posting 
code that is different than the room posting code for both % or $ 
amounts.  If the posting code field is left blank, the Room type / Rate 
type posting code will be used as default. 

 183612  

Routing of Taxes Not Allowed 
An enhancement has been added to provide a message to read 
“Routing of taxes is not allowed”, when users enter a tax code on the 
charge routing rules screen. 

 161722  

Warning Message for Missing Inventory – In-house & Reserved  161865  
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Status 
A warning message will display on the Guest Reservation screen when 
a reservation is in house and does not have inventory for all days.  

Housekeeping Credit Calculation based on Room Type 
Occupancy. 
A feature has been added to the housekeeping credit calculations to 
determine credits based on total guest count (occupancy) on room 
reservation assignment chart, in addition to service level and room 
type.  Credits can be configured based on Extra Person Category 
(Adult, children Etc) per room type.  This is configured in Front Desk 
Maintenance > Set up > Housekeeping > Define Service Levels > 
Choose desired Service > Window > Credits/Cost by Room Type Extra 
Persons. 

 163812  

Order of Reservations Screen added Client Extra Information 
Screen  
The Client Extra Information Screen can now be configured to pop up 
during reservation creation and check in for Front Desk and Spa. This 
allows for recording Health Attributes, Age, weight and Height and 
more. This can be configured in Front Desk Maintenance > Set Up > 
Order of Reservations Screens. 

 163828  

Client Extra Information Screen added Height and Weight 
measurement fields. 
The ability to capture the Height and Weight of a guest has been added 
to the Client Extra Information Screen.  The preferred units of 
measurement for Height & Weight can be configured in Front Desk 
Maintenance > Front Desk Global Setup.  Users can enter their desired 
units of measurement on this screen.  i.e. Kg, Lb Stone, Inches or Feet 

 163835  

Pro Forma Consolidated Invoice – Spa and Facilities Gratuities 
Spa and Facilities gratuities are now included in future charge routing 
calculations for the Pro Forma Consolidated Invoice. 

 165978  

Front Desk Maintenance – Alert Configuration Enhancement 
An enhancement has been made to the Alert Configuration > Room 
Occupancy Alert to allow for auto alerts to be configured by Room Type 
or Room Type Group.  

 135083  

 

Description Available 
in 

Version 

Incident 
# 

Global 
System 
Option 

# 

365 Day Report – Default ‘Unpicked Rooms’ 
The 365 Day Report’s ‘Unpicked Rooms’ flag’s default has been 
changed to auto default to a Y. 

 185471  

Clerk Performance Report – Include Group Guest Y / N Default 
option. 
Users can now configure the auto default value for “Include Group 
Guests” to be Y or N. In Global Maintenance > System Options > 
Option # 633, can be configured with a Y or N to control the auto 
default. 

 163091 633 

Meal Plan Guest List & Meal Plan Guest Count available as CSV. 
Both Meal Reports are able to be run as CSV (Excel) reports.  As well 
the option to print by Extra Person Category or expanded Extra Person 
Code has been added for CSV run. 

 163810  
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Closing Balance Report available as CSV 
Closing Balance Report is now able to be run as CSV (Excel). 

 166245  

Guest Ledger Report available as CSV  
Guest Ledger Report is now able to be run as CSV (Excel). 

 166246  

 

Description Available 
in 

Version 

Incident 
# 

Global 
System 
Option 

# 

Owner Commission Inquiry - Cancel Remittance for Owner 
Cheques 
On the Owner Commission Inquiry Screen, from the Window menu, 
Cancel Remittance has been added for any cheque remittance. The 
cancel process will verify that the details making up the amount and 
cancel amount balance. If an EFT remittance is selected for 
cancellation, a pop up will let the user know this is not possible. 

 100715  

 

Description Available 
in 

Version 

Incident 
# 

Global 
System 
Option 

# 

Order of Booking Screens for Spa  
Added "Create", “Check in” and “Access” to Spa Maintenance > Set Up 
> Order of Booking Screens.  The Health Attributes Screen can now be 
configured to auto pop up at time of booking or check in. 

 173423  

Service Package Rate – Copy  
Spa Maintenance > Service > Service Package Header, a Copy button 
will allow for copy of package rate with options for Pkg Type, Pkg Code, 
Guest Type and From / To Date.  

 174240  

Spa and Activities Folios - Enhancements 
Under the Inquiry menu > Spa and Activities Folios screen has added 
the following: 

1) Added F3 to allow searching by booking and folio number 
2) Added an option of “Include With Balance” to the screen 
3) Added “Print” button 
4) Added Window option to allow changing property 

 166326  

Description Available 
in 
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Incident 
# 

Global 
System 
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Service Report 
Booking Phone Number has been added to the Spa Service Report. 

 181203  
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Shift Report and Posting Audit Report 
The Shift Report and Posting Audit Report now display the booking 
number and guest name for Spa Bookings. 

 165802  

 

Description Available 
in 

Version 

Incident 
# 

Global 
System 
Option 

# 

Modify Quantity Booked 
Facility Booking Entry screen, users now have the ability to modify the 
quantity booked field on the fly.  

 180400  

Facilities Mandatory Information Fields 
In Spa Maintenance > Facilities > Facility Mandatory Information 
Options have been added.  Based on Booking Status, CF, TN & WL, 
fields for Participant, Guest Type, Facility, Instructor, Source, 
Subsource, Phone number, Credit Card and Email address can be 
made as mandatory entry fields on the Booking.  Mandatory entry fields 
show as Red on the Booking Screen. 

 180408  

New -  Facility Code Minimum and Maximum Age, Weight and 
Height 
In Spa Maintenance > Facilities > Facility Type > Window > Facility 
Code, new information only fields have been added record the 
Minimum and maximum age, weight and height requirements for each 
Facility Code.  These information only fields will display on the booking 
screens, by facility code selected. 

 163837  

New - Two Week Schedule – Filter by Facility Code 
The ability to filter by Facility Code has been added to the Two Week 
Schedule.  

 165664  

Order of Booking Screens for Facilities 
Added "Create", “Access” and “Check in” to Spa Maintenance > Set Up 
> Order of Booking Screens.  The Health Attributes Screen can now be 
configured to auto pop up at time of booking 

 173423  

Rapid Search - Guest – Web Confirmation # 
The ability to search by Web Confirmation number has been added to 
the Facility Rapid Search. 

 175535  

Client Profile Client Extra Information Screen added Height and 
Weight measurement fields. 
The ability to capture the Height and Weight of a guest has been added 
to the Client Extra Information Screen.  The preferred units of 
measurement for Height & Weight can be configured in Front Desk 
Maintenance > Front Desk Global Setup.  Users can enter their desired 
units of measurement on this screen.  i.e. Kg, Lb Stone, Inches or Feet 
 
The entered Age, Weight and Height on the Client Profile, Client Extra 
Information Screen will auto display on a Facilities Booking. 

 163835  

New - Facility - Client Booking History  
Added Facility history field to facility booking screen, after Participant 
Name. A listing of all the previous facility bookings will be displayed. 

 175537  

 

 



 

 

 

 

Page 5 of 7 

Description Available 
in 
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# 

Global 
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Added Status to Print Options on Facilities Report  
On the Facilities Report, an option has been added to allow reporting 
based on Booking Status, CF, TN, WL, CA. 

 182553  

 

Description Available 
in 
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Incident 
# 

Global 
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# 

Member EFT – Property Specific 
The Member EFT now includes the property code in the file name, and 
only folios that belong to the property.  

 183967  

Member Dues can be Applied on the Member Profile 
Member Dues Codes can now be manually assigned to a Member 
Profile.  Dues will be posted based on Due Code assigned on Profile, 
and can be different that due code assigned to Member Type.  If no due 
code assigned, Due Code assigned to Member Type will apply.  

 167701  

 

Description Available 
in 
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Incident 
# 

Global 
System 
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# 

Colour Code for Booking Status 
The GRC and Five-Week Plan screens now use the same colours as 
the Dashboard and the One-Day Availability screen. 

 182671  

Contract Merge – Option of Room Description or Rm Type Code 
The option to print the Room Type Description or the Room Type code 
is now available for the Contract Merge document. 

 185585  

New - Booking Templates 

This new feature allows users to create and then select from 
Multiple Templates during the Booking Process (from the GRC or 
Make / Edit Booking screen) or when converting an Inquiry from 
the Inquiry screen.  
Templates can be setup to include selected fields on the Main 
Booking Screen, Event Detail Screens, Function Room Booking 
Screens, Function Room Setups, F&B Menus, Inventory and 
Special Charges. When making new bookings users are 
prompted with an option to select a Template or to proceed with 
a booking without a Template.  When users chose to select a 
Template, options to include or exclude (Y/N) items from the 
template in the new booking.  For example, a user may wish to 
copy the F&B Items but not the Function Space.   Once the 

 163817  
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template options are selected, Maestro will create the new 
booking and verify that all items including function rooms are 
available.  In the event that an item is not available, Maestro 
provides an error log for reference.  
 
Users can configure as many templates as required.  To 
configure, from the S&C Module, the booking menu, chose 
Booking Templates.  To create a new template, press F6, or from 
an existing template, from the window drop down, chose 
Duplicate and an existing template can be duplicated.  There is 
an F3 Search feature, allowing for template search by Market 
Segment or number of nights.  To delete a Template, F7. 

 

Description Available 
in 

Version 

Incident 
# 

Global 
System 
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# 

New - Retail POS Folios 
A new Retail POS Folios Screen has been added. From the Query 
menu > Retail POS Folios.  Users can enter the desired date range, 
with or without a balance option, and view on screen or print. F5 on the 
POS Seq # to view items detail, and F5 on Folio to view folio details. 

 168036 
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ResWave on-line Owner Reporting view in Real Time 
ResWave has been enhanced to allow real time viewing of Owner 
Reports as opposed to pre-saved PDF files.  Please contact the 
ResWave team at webservices@maestropms.com to implement. 
 

 174568  
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# 
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Loyalty Setup Option Screen 
F8 Lookup/edit values are added for Points Expiry Model field, 
Governing Model field and Discount Posting Code field on the Loyalty 
Setup screen. 

 165103  
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NO CHANGES TO THE FOLLOWING AREAS OF MAESTRO PMS FROM VERSION  

5.4.001 - 5.4.036 

 

 

 

  


